Jun 5, 2012 at 5:10 PM
Edited Jun 5, 2012 at 5:14 PM
I have entered a topic about paging in workitem 37, but I guess I should have started this as a discussion rather than issue, sorry about that. Now I'm re-starting the discussion.
I made some more thoughts, and just wanted to share, hoping doing so may make our thoughts clearer.
One catch I found was, if we were going to support column paging, we would have to expose a new property because List<Column> cannot support paging.
I guess the new property probably will look something like:
public CassandraQueryable<CassandraEntity<IEnumerable<Column>>> Columns
The name "Columns" is consistent with existing properties, but it could be confusing for new users, because what it actually returns is a sequence of rows, and each row has columns.
The initial design might have chosen "Column" or "ColumnList" because it needs to distinguish from SuperColumn, but now SuperColumn is deprecated. I wonder "Rows" maybe a better name.
And that said, as sabro said, it'd probably be a rather major change to support get_paged_slice. Developers have to use new APIs to get its benefit.
Am I on the right track? Any opinions?